<!DOCTYPE html>
<html class="no-js mh-two-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/cdn-cgi/apps/head/DkoEC9W5rlNFSrMzPKHqaJqOgzQ.js"></script><link rel="profile" href="https://gmpg.org/xfn/11" />

<script type='text/javascript'>mapp = window.mapp || {}; mapp.data = [];</script>
<title>Oswego 6th Ward Councilor Seeks 2nd Term &#8211; Oswego County Today &#8211; Oswego County Home Page</title>
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oswego County Today - Oswego County Home Page &raquo; Feed" href="https://oswegocountytoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oswego County Today - Oswego County Home Page &raquo; Comments Feed" href="https://oswegocountytoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oswego County Today - Oswego County Home Page &raquo; Oswego 6th Ward Councilor Seeks 2nd Term Comments Feed" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/oswegocountytoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://oswegocountytoday.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-email-subscribe-css' href='https://oswegocountytoday.com/wp-content/plugins/jetpack/modules/shortcodes/css/jetpack-email-subscribe.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mappress-leaflet-css' href='https://oswegocountytoday.com/wp-content/plugins/mappress-google-maps-for-wordpress/css/leaflet/leaflet.css?ver=1.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='mappress-css' href='https://oswegocountytoday.com/wp-content/plugins/mappress-google-maps-for-wordpress/css/mappress.css?ver=2.50.10' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css' href='https://oswegocountytoday.com/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-child-css' href='https://oswegocountytoday.com/wp-content/themes/mh-magazine%20-%20child/style.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css' href='https://oswegocountytoday.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700%7cTitillium+Web:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp_font_awesome-css' href='https://use.fontawesome.com/releases/v5.6.3/css/all.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css' href="https://oswegocountytoday.com/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.5.1" type='text/css' media='all' />
<link rel='stylesheet' id='default-styles-css' href="https://oswegocountytoday.com/wp-content/plugins/business-directory-plugin/themes/default/assets/styles.css?ver=4.0.4" type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://oswegocountytoday.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.9' type='text/css' media='all' />
<script type='text/javascript' src='https://oswegocountytoday.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20181228'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://oswegocountytoday.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://oswegocountytoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://oswegocountytoday.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='A. Jim Richardson, 75' href='https://oswegocountytoday.com/a-jim-richardson-75/obituaries/funeral-homes/allanson-glanville-tappan-funeral-home/' />
<meta name="generator" content="WordPress 5.0.3" />
<link rel="canonical" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" />
<link rel='shortlink' href='https://wp.me/p1shcx-13Mx' />
<link rel="alternate" type="application/json+oembed" href="https://oswegocountytoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Foswegocountytoday.com%2Foswego-6th-ward-councilor-seeks-2nd-term%2Flead-story%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://oswegocountytoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Foswegocountytoday.com%2Foswego-6th-ward-councilor-seeks-2nd-term%2Flead-story%2F&#038;format=xml" />
<script>
    function hasWKGoogleAnalyticsCookie() {
      return (new RegExp('wp_wk_ga_untrack_' + document.location.hostname) ).test(document.cookie);
    }
    </script>
<script>
      if( !hasWKGoogleAnalyticsCookie() ) {
        //Google Analytics
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
        ga('create', '', 'auto');

                      ga('set', 'anonymizeIp', true);
          
        ga('send', 'pageview');
      }
      </script>
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #004e82; }
.mh-extra-nav-bg { background: rgba(0, 78, 130, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #004e82; background: rgba(0, 78, 130, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(0, 78, 130, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #004e82; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #129abc; background: rgba(18, 154, 188, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #129abc; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #129abc; }
.mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #129abc; }
</style>
<!--[if lt IE 9]>
<script src="https://oswegocountytoday.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 18px; font-size: 1.125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Titillium Web", sans-serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>

<meta property="og:type" content="article" />
<meta property="og:title" content="Oswego 6th Ward Councilor Seeks 2nd Term" />
<meta property="og:url" content="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" />
<meta property="og:description" content="The Port City’s Sixth Ward Councilor is seeking a second term. Oswego native Ron Tesoriero sat down recently with Oswego County Today to announce his re-election bid. The city is going in the right…" />
<meta property="article:published_time" content="2019-02-04T04:50:00+00:00" />
<meta property="article:modified_time" content="2019-02-04T04:50:02+00:00" />
<meta property="og:site_name" content="Oswego County Today - Oswego County Home Page" />
<meta property="og:image" content="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg" />
<meta property="og:image:width" content="445" />
<meta property="og:image:height" content="426" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Oswego 6th Ward Councilor Seeks 2nd Term" />
<meta name="twitter:image" content="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://oswegocountytoday.com/wp-content/uploads/2016/08/OCT_Logo-150x56.jpg" sizes="32x32" />
<link rel="icon" href="https://oswegocountytoday.com/wp-content/uploads/2016/08/OCT_Logo.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://oswegocountytoday.com/wp-content/uploads/2016/08/OCT_Logo.jpg" />
<meta name="msapplication-TileImage" content="https://oswegocountytoday.com/wp-content/uploads/2016/08/OCT_Logo.jpg" />
<style type="text/css" id="wp-custom-css">
				#mh-ticker-loop-bottom {
    height: 35px;
    overflow: hidden;
    color: red;
}
.mh-header-2 {
    margin: 20px 20px 20px 0;
    text-align: left;
    overflow: hidden;
}
.entry-thumbnail img {
    width: auto;
}			</style>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-252869 single-format-standard custom-background wp-custom-logo mh-wide-layout mh-right-sb mh-loop-layout1 mh-widget-layout4 mh-header-transparent mh-loop-hide-caption wpbdp-with-button-styles" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="bs_zones-91" class="mh-widget mh-header-1 bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(68227, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div></aside>
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-sidebar-container"><ul id="menu-sidebar" class="menu"><li id="menu-item-250047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-250047"><a href="https://oswegocountytoday.com/submit-a-news-realease/"><b><i>Send Us Your News</i></b></a></li>
<li id="menu-item-135776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135776"><a href="https://oswegocountytoday.com/contact-us/letters-to-the-editor/">Submit Letters to the Editor</a></li>
<li id="menu-item-230889" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230889"><a href="https://oswegocountytoday.com/obituary-submition/">Obituary Submission</a></li>
</ul></div> </nav>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://oswegocountytoday.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="266" height="103" src="https://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5.png" class="custom-logo" alt="Oswego County Today &#8211; Oswego County Home Page" itemprop="logo" srcset="https://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5.png 266w, https://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5-150x58.png 150w" sizes="(max-width: 266px) 100vw, 266px" data-attachment-id="248439" data-permalink="https://oswegocountytoday.com/cropped-oct_logo-5-png/" data-orig-file="https://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5.png" data-orig-size="266,103" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="cropped-OCT_Logo-5.png" data-image-description="&lt;p&gt;http://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5.png&lt;/p&gt;
" data-medium-file="https://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5.png" data-large-file="https://oswegocountytoday.com/wp-content/uploads/2017/09/cropped-OCT_Logo-5.png" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="bs_zones-59" class="mh-widget mh-header-2 bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3433, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-73602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-73602"><a href="https://oswegocountytoday.com">Home</a>
<ul class="sub-menu">
<li id="menu-item-73623" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-73623"><a href="https://oswegocountytoday.com/category/lead-story/">Lead Story</a></li>
<li id="menu-item-149540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149540"><a href="https://oswegocountytoday.com/category/emergency/">Emergency Posts</a></li>
<li id="menu-item-128470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-128470"><a href="https://oswegocountytoday.com/category/weather/">Today&#8217;s Weather</a></li>
</ul>
</li>
<li id="menu-item-73614" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73614"><a href="https://oswegocountytoday.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-236423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236423"><a href="https://oswegocountytoday.com/category/mayorminutes/">Mayor Minutes</a></li>
<li id="menu-item-73616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73616"><a href="https://oswegocountytoday.com/category/news/fulton/">Fulton Daily News</a></li>
<li id="menu-item-73617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73617"><a href="https://oswegocountytoday.com/category/news/oswego/">Oswego Daily News</a></li>
<li id="menu-item-73615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73615"><a href="https://oswegocountytoday.com/category/community/">Community</a></li>
<li id="menu-item-73625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73625"><a href="https://oswegocountytoday.com/category/oswego-tourism/">Oswego Tourism</a></li>
<li id="menu-item-131105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131105"><a href="https://oswegocountytoday.com/category/raidernet-daily/">RaiderNet Daily</a></li>
<li id="menu-item-116546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116546"><a href="https://oswegocountytoday.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-116548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116548"><a href="https://oswegocountytoday.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
<li id="menu-item-116549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116549"><a href="https://oswegocountytoday.com/category/opinion/ritchie-opinion/">Ritchie</a></li>
<li id="menu-item-116547" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116547"><a href="https://oswegocountytoday.com/category/opinion/barclay-opinion/">Barclay</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-73618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73618"><a href="https://oswegocountytoday.com/category/obituaries/">Obituaries</a>
<ul class="sub-menu">
<li id="menu-item-200925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-200925"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/allanson-glanville-tappan-funeral-home/">Allanson Glanville Tappan Funeral Home</a></li>
<li id="menu-item-200705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-200705"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/dain-cullinan-funeral-home/">Dain-Cullinan Funeral Home</a></li>
<li id="menu-item-200303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-200303"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/dowdle-funeral-home/">Dowdle Funeral Home</a></li>
<li id="menu-item-73634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73634"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/foster-funeral-home-funeral-homes/">Foster Funeral Home</a></li>
<li id="menu-item-246243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-246243"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/menter/">Menter Funeral Home</a></li>
<li id="menu-item-73633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73633"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/sugar-and-sugar-scanlon-funeral-homes/">Sugar and Sugar Scanlon Funeral Homes</a></li>
</ul>
</li>
<li id="menu-item-73620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73620"><a href="https://oswegocountytoday.com/category/police/">Police Blotter</a>
<ul class="sub-menu">
<li id="menu-item-73621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73621"><a href="https://oswegocountytoday.com/category/police/police-blotter-fdn/">Fulton Police</a></li>
<li id="menu-item-73622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73622"><a href="https://oswegocountytoday.com/category/police/police-blotter-odn/">Oswego Police</a></li>
<li id="menu-item-73632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73632"><a href="https://oswegocountytoday.com/category/police/sherrifs-department-fdn/">Sheriff&#8217;s Department</a></li>
</ul>
</li>
<li id="menu-item-180779" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-180779"><a href="https://oswegocountytoday.com/category/health/newborns/">Newborns</a>
<ul class="sub-menu">
<li id="menu-item-73627" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73627"><a href="https://oswegocountytoday.com/category/health/">Health</a></li>
<li id="menu-item-73629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73629"><a href="https://oswegocountytoday.com/category/health/oswegohealth/">Oswego Health</a></li>
<li id="menu-item-250048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250048"><a href="https://oswegocountytoday.com/category/health/pethealth/">Pet Health</a></li>
</ul>
</li>
<li id="menu-item-149546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149546"><a href="https://oswegocountytoday.com/category/realestate/">Real Estate</a></li>
<li id="menu-item-149548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149548"><a href="https://oswegocountytoday.com/category/sports/">Sports</a></li>
<li id="menu-item-150766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150766"><a href="https://oswegocountytoday.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
<li id="menu-item-210439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-210439"><a title="CNY Music and Entrtainment" href="http://cnyalive.com">CNY Alive!</a></li>
</ul>
</li>
<li id="menu-item-149561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-149561"><a href="https://oswegocountytoday.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
<li id="menu-item-149556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149556"><a href="https://oswegocountytoday.com/contact-us/advertise-with-us/">Advertise</a></li>
<li id="menu-item-149559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149559"><a href="https://oswegocountytoday.com/contact-us/our-police-blotter-policy/">Our Police Blotter Policy</a></li>
<li id="menu-item-149560" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149560"><a href="https://oswegocountytoday.com/contact-us/website-terms-of-use/">Website Terms of Use</a></li>
<li id="menu-item-247332" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-247332"><a href="https://oswegocountytoday.com/contact-us/employment-with-dot-publishing-inc-reporter/">Employment with Dot Publishing Inc. – Reporter</a></li>
</ul>
</li>
</ul></div> </nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom"> </ul>
</div>
</div> </div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://oswegocountytoday.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </aside>
</div>
</div>
</div>
<div class="mh-container mh-container-outer">
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><article id="post-252869" class="post-252869 post type-post status-publish format-standard has-post-thumbnail hentry category-lead-story">
<header class="entry-header clearfix">

<div align="center">
<script>broadstreet.zone(46799);</script>
</div>

<h1 class="entry-title">Oswego 6th Ward Councilor Seeks 2nd Term</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/02/">February 3, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://oswegocountytoday.com/author/steve/">Steve Yablonski</a></span>
</div>
</header>
<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-445x381.jpg" alt="Ron Tesoriero" title="KODAK Digital Still Camera" />
<figcaption class="wp-caption-text">Ron Tesoriero</figcaption>
</figure>
<div style="margin:5px auto; margin-bottom: 15px;"><script data-cfasync="false" type="text/javascript">broadstreet.zone(68227, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div><p>OSWEGO – The Port City’s Sixth Ward Councilor is seeking a second term.</p>
<p>Oswego native Ron Tesoriero sat down recently with Oswego County Today to announce his re-election bid.</p>
<figure id="attachment_252870" style="width: 300px" class="wp-caption alignleft"><a href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/attachment/kodak-digital-still-camera-540/" rel="attachment wp-att-252870"><img data-attachment-id="252870" data-permalink="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/attachment/kodak-digital-still-camera-540/" data-orig-file="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg" data-orig-size="445,426" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;3&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;KODAK PIXPRO AZ401&quot;,&quot;caption&quot;:&quot;KODAK Digital Still Camera&quot;,&quot;created_timestamp&quot;:&quot;1544471954&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.3&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.058823529411765&quot;,&quot;title&quot;:&quot;KODAK Digital Still Camera&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="KODAK Digital Still Camera" data-image-description="&lt;p&gt;Ron Tesoriero&lt;/p&gt;

" data-medium-file="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-300x287.jpg" data-large-file="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg" class="size-medium wp-image-252870" src="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-300x287.jpg" alt="Ron Tesoriero" width="300" height="287" srcset="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-300x287.jpg 300w, https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-150x144.jpg 150w, https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg 445w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption class="wp-caption-text">Ron Tesoriero</figcaption></figure>
<div style="margin:5px auto; margin-bottom: 15px;"><script data-cfasync="false" type="text/javascript">broadstreet.zone(68117, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div>
<p>The city is going in the right direction, he said, adding that he wants to keep the momentum going in his ward and the entire city.</p>
<p>“There is still work to be done, don’t get me wrong,” he said. “We’ve got a lot accomplished recently and we want to keep going.”</p>
<p>First elected in 2017, Tesoriero said it takes a year to learn and then you are able to start getting things done.</p>
<p>The election process starts earlier now; he said explaining why he announced his re-election bid in early February. Primary elections will be held June 25; the general election on Nov. 5.</p>
<p>“My goal is to oversee some of the projects that we have on the books and see them through to finish,” he said. “I want to keep the promises I made to my constituents and keep moving forward. I want to improve the ward, make it as good as we can. That’s my first priority. Responding to the needs of Sixth Ward residents, that’s at the top of the list for me.”</p>
<p>Some of his other goals in a second term include: increasing the tax base, retaining senior citizens and youth.</p>
<p>“Another goal of mine is to retain seniors, to be able to stay in their homes as long as they possibly can,” he said. “And, hopefully be able to retain our youths with some jobs that are fulfilling enough. That’s also important. Our greatest resource is our children.”</p>
<p>“Us, as a city, are doing a better job taking care of our structures; the roads are in good shape, we have a paving plan in place,” he continued. “I have some park enhancements coming up this year which are going to be nice. We’re going to have the first handicap accessible park in the city of Oswego. I’m very proud of that<br />
We’ve built a good team, under the leadership of (Council) president (Rob) Corradino and vice president (Kevin) Hill. We’ve had good continuity. We don’t always agree all the time but we figure it out and get things done. We get things done.”</p>
<p>In the next term, he’d get another budget to get things done.</p>
<p>“Then, if I’m successful, then you can concentrate on more stuff. We as a city are growing, getting more business to ease the tax burden, we had the first tax relief in many, many years and didn’t tax away from surplus or reduce services and we lowered the sewer rates,” he said.</p>
<p>The city has to repurpose itself; it has to find where it’s going, the councilor pointed out.</p>
<p>“The days of what it used to be are gone, we have to evolve and change. We have to think ahead and think about where we’re gong in the next 10 years or more and plot a course,” he said. “I think Mayor (Billy) Barlow is an aggressive young mayor that sees this. He’s involved in this city. He’s lived here his whole life and knows that we have to change with the times and I’m glad to be a part of that. It’s been exciting. I love the fact that I’ve had the opportunity to work with him and the current council.”</p>
<p>He hopes to complete more paving and sidewalk repairs this year and add stop signs to slow down traffic in some areas that he thinks are dangerous, especially in both park areas.</p>
<p>He’d also like to see more trees in the parks and neighborhoods.</p>
<p>“We have got areas where we can plant them that they won’t interfere with sewer lines like some have in the past,” he said.</p>
<p>The previous council set up some things that the current council has been able to fulfill, he said.</p>
<p>“You have to give them credit.<br />
We want to do what the mayor said (in his State of the City address) – keep the momentum going. I think we have a good start, we had a great year last year and have a good year going now,” he said. “We’re going to have a better year. I think everyone’s going to be pleasantly surprised at what we can do this year.”</p>
<p>Another tax reduction isn’t out of the realm of possibilities, he said.</p>
<p>“We’re turning the corner. It’s given people some hope that costs are going to go down, our services are up and we’ve done it with less people,” he said. “All the departments are working well, with less people, working well together. We’re very proud of that.”</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" data-text="Oswego 6th Ward Councilor Seeks 2nd Term">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252869-5c57f7d59c192' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252869&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252869-5c57f7d59c192' data-name='like-post-frame-21515645-252869-5c57f7d59c192'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts'>
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div> </div></article><div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment </span>
</h4> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://oswegocountytoday.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br /><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br /><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br /><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br /><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='252869' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="179213328e" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="15" /></p> </form>
</div>
</div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="mh_magazine_custom_posts-33" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://oswegocountytoday.com/category/lead-story/" class="mh-widget-title-link">Headlines</a></span></h4> <ul class="mh-custom-posts-widget clearfix"> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-252869 post type-post status-publish format-standard has-post-thumbnail category-lead-story">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" title="Oswego 6th Ward Councilor Seeks 2nd Term"><img width="326" height="245" src="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="Ron Tesoriero" srcset="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-326x245.jpg 326w, https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" data-attachment-id="252870" data-permalink="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/attachment/kodak-digital-still-camera-540/" data-orig-file="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg" data-orig-size="445,426" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;3&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;KODAK PIXPRO AZ401&quot;,&quot;caption&quot;:&quot;KODAK Digital Still Camera&quot;,&quot;created_timestamp&quot;:&quot;1544471954&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.3&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.058823529411765&quot;,&quot;title&quot;:&quot;KODAK Digital Still Camera&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="KODAK Digital Still Camera" data-image-description="&lt;p&gt;Ron Tesoriero&lt;/p&gt;
" data-medium-file="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T-300x287.jpg" data-large-file="https://oswegocountytoday.com/wp-content/uploads/2019/02/councilor-Ron-T.jpg" /> </a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" title="Oswego 6th Ward Councilor Seeks 2nd Term">
Oswego 6th Ward Councilor Seeks 2nd Term </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/02/">February 3, 2019</a></span>
</div>
</div>
<div class="mh-excerpt"><p>The Port City’s Sixth Ward Councilor is seeking a second term. Oswego native Ron Tesoriero sat down recently with Oswego County Today to announce his re-election bid. The city is going in the right direction, he said, adding that he wants to keep the momentum going in his ward and the entire city. <a class="mh-excerpt-more" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" title="Oswego 6th Ward Councilor Seeks 2nd Term">[&#8230;]</a></p>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" data-text="Oswego 6th Ward Councilor Seeks 2nd Term">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252869-5c57f7d5a0fac' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252869&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252869-5c57f7d5a0fac' data-name='like-post-frame-21515645-252869-5c57f7d5a0fac'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div> </div>
</div>
</li> </ul></div><div id="search-9" class="mh-widget widget_search"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Search</span></h4><form role="search" method="get" class="search-form" action="https://oswegocountytoday.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div><div id="mh_magazine_custom_posts-30" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://oswegocountytoday.com/category/news/" class="mh-widget-title-link">News</a></span></h4> <ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-252859 post type-post status-publish format-standard has-post-thumbnail category-fulton">
<div class="mh-custom-posts-large-inner clearfix">
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/fulton-man-airlifted-to-hospital-following-snowmobile-crash/news/fulton/" title="Fulton Man Airlifted to Hospital Following Snowmobile Crash">
Fulton Man Airlifted to Hospital Following Snowmobile Crash </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/02/">February 2, 2019</a></span>
</div>
</div>
<div class="mh-excerpt"><p>Preliminary investigation has revealed, Jeffery L. Wise, 41, from Fulton, was operating a 2003 Polaris Snowmobile on Trail C5 when he lost control on a curve and struck a tree. <a class="mh-excerpt-more" href="https://oswegocountytoday.com/fulton-man-airlifted-to-hospital-following-snowmobile-crash/news/fulton/" title="Fulton Man Airlifted to Hospital Following Snowmobile Crash">[&#8230;]</a></p>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/fulton-man-airlifted-to-hospital-following-snowmobile-crash/news/fulton/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/fulton-man-airlifted-to-hospital-following-snowmobile-crash/news/fulton/" data-text="Fulton Man Airlifted to Hospital Following Snowmobile Crash">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/fulton-man-airlifted-to-hospital-following-snowmobile-crash/news/fulton/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/fulton-man-airlifted-to-hospital-following-snowmobile-crash/news/fulton/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252859-5c57f7d5a5dcf' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252859&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252859-5c57f7d5a5dcf' data-name='like-post-frame-21515645-252859-5c57f7d5a5dcf'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div> </div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-252813 post type-post status-publish format-standard has-post-thumbnail category-oswego">
<div class="mh-custom-posts-large-inner clearfix">
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/university-police-issues-body-worn-cameras-to-patrol-officers/news/oswego/" title="University Police Issues Body-Worn Cameras To Patrol Officers">
University Police Issues Body-Worn Cameras To Patrol Officers </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/02/">February 2, 2019</a></span>
</div>
</div>
<div class="mh-excerpt"><p>University Police at SUNY Oswego deployed its body-worn cameras for patrol officers today (Feb. 1), mobilizing the point-of-view evidence-capturing devices that law enforcement departments across the country are adopting. <a class="mh-excerpt-more" href="https://oswegocountytoday.com/university-police-issues-body-worn-cameras-to-patrol-officers/news/oswego/" title="University Police Issues Body-Worn Cameras To Patrol Officers">[&#8230;]</a></p>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/university-police-issues-body-worn-cameras-to-patrol-officers/news/oswego/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/university-police-issues-body-worn-cameras-to-patrol-officers/news/oswego/" data-text="University Police Issues Body-Worn Cameras To Patrol Officers">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/university-police-issues-body-worn-cameras-to-patrol-officers/news/oswego/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/university-police-issues-body-worn-cameras-to-patrol-officers/news/oswego/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252813-5c57f7d5a9c48' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252813&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252813-5c57f7d5a9c48' data-name='like-post-frame-21515645-252813-5c57f7d5a9c48'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div> </div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-252821 post type-post status-publish format-standard has-post-thumbnail category-oswego">
<div class="mh-custom-posts-large-inner clearfix">
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/mayor-barlow-announces-100k-grant-for-expansion-of-northland-filter-adding-50-jobs/news/oswego/" title="Mayor Barlow Announces $100k Grant For Expansion of Northland Filter, Adding 50 Jobs">
Mayor Barlow Announces $100k Grant For Expansion of Northland Filter, Adding 50 Jobs </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/02/">February 1, 2019</a></span>
</div>
</div>
<div class="mh-excerpt"><p>Mayor Billy Barlow announced today (February 1) Northland Filter, a filter manufacturing company, will purchase a building at 249A Mitchell St., Oswego, and conduct a multi-million 15-30,000 square foot expansion adding 50 jobs in the next two years. The 32,500 square foot facility was previously owned by Operation Oswego County and a $100,000 grant from the city of Oswego will aid the purchase of the building by Northland Filter, LLC. <a class="mh-excerpt-more" href="https://oswegocountytoday.com/mayor-barlow-announces-100k-grant-for-expansion-of-northland-filter-adding-50-jobs/news/oswego/" title="Mayor Barlow Announces $100k Grant For Expansion of Northland Filter, Adding 50 Jobs">[&#8230;]</a></p>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/mayor-barlow-announces-100k-grant-for-expansion-of-northland-filter-adding-50-jobs/news/oswego/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/mayor-barlow-announces-100k-grant-for-expansion-of-northland-filter-adding-50-jobs/news/oswego/" data-text="Mayor Barlow Announces $100k Grant For Expansion of Northland Filter, Adding 50 Jobs">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/mayor-barlow-announces-100k-grant-for-expansion-of-northland-filter-adding-50-jobs/news/oswego/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/mayor-barlow-announces-100k-grant-for-expansion-of-northland-filter-adding-50-jobs/news/oswego/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252821-5c57f7d5ab58d' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252821&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252821-5c57f7d5ab58d' data-name='like-post-frame-21515645-252821-5c57f7d5ab58d'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div> </div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-252775 post type-post status-publish format-standard has-post-thumbnail category-oswego">
<div class="mh-custom-posts-large-inner clearfix">
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/mayor-proposes-expanding-tax-exemption-eligibility-for-senior-citizens-in-oswego/news/oswego/" title="Mayor Proposes Expanding Tax Exemption Eligibility For Senior Citizens in Oswego">
Mayor Proposes Expanding Tax Exemption Eligibility For Senior Citizens in Oswego </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/01/">January 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt"><p>Mayor Billy Barlow is proposing to update and expand several tax exemptions for Oswego residents 65 years old and older, likely living on fixed incomes. The proposal raises the income threshold for seniors to be eligible for an exemption from city property taxes, along with water bills from a $25,000 cap to a $30,500 cap, an alteration he said is long overdue. <a class="mh-excerpt-more" href="https://oswegocountytoday.com/mayor-proposes-expanding-tax-exemption-eligibility-for-senior-citizens-in-oswego/news/oswego/" title="Mayor Proposes Expanding Tax Exemption Eligibility For Senior Citizens in Oswego">[&#8230;]</a></p>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/mayor-proposes-expanding-tax-exemption-eligibility-for-senior-citizens-in-oswego/news/oswego/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/mayor-proposes-expanding-tax-exemption-eligibility-for-senior-citizens-in-oswego/news/oswego/" data-text="Mayor Proposes Expanding Tax Exemption Eligibility For Senior Citizens in Oswego">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/mayor-proposes-expanding-tax-exemption-eligibility-for-senior-citizens-in-oswego/news/oswego/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/mayor-proposes-expanding-tax-exemption-eligibility-for-senior-citizens-in-oswego/news/oswego/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252775-5c57f7d5aea5d' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252775&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252775-5c57f7d5aea5d' data-name='like-post-frame-21515645-252775-5c57f7d5aea5d'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div> </div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-252776 post type-post status-publish format-standard has-post-thumbnail category-fulton">
<div class="mh-custom-posts-large-inner clearfix">
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/fulton-remains-target-district-despite-all-six-schools-in-good-standing/news/fulton/" title="Fulton Remains Target District Despite All Six Schools In Good Standing">
Fulton Remains Target District Despite All Six Schools In Good Standing </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2019/01/">January 31, 2019</a></span>
</div>
</div>
<div class="mh-excerpt"><p>The New York State Education Department recently announced the 2018-2019 accountability status for school districts across the state based on the Every Students Succeeds Act (ESSA.) Betsy Conners, Director of Instruction and Assessment at Fulton City School District, said the district had quite a bit to celebrate from the results. <a class="mh-excerpt-more" href="https://oswegocountytoday.com/fulton-remains-target-district-despite-all-six-schools-in-good-standing/news/fulton/" title="Fulton Remains Target District Despite All Six Schools In Good Standing">[&#8230;]</a></p>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/fulton-remains-target-district-despite-all-six-schools-in-good-standing/news/fulton/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/fulton-remains-target-district-despite-all-six-schools-in-good-standing/news/fulton/" data-text="Fulton Remains Target District Despite All Six Schools In Good Standing">Tweet</a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/fulton-remains-target-district-despite-all-six-schools-in-good-standing/news/fulton/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/fulton-remains-target-district-despite-all-six-schools-in-good-standing/news/fulton/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-21515645-252776-5c57f7d5b1952' data-src='https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=252776&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-252776-5c57f7d5b1952' data-name='like-post-frame-21515645-252776-5c57f7d5b1952'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div> </div>
</div>
</li> </ul></div> </aside> </div>
<aside class="mh-widget-col-1 mh-sidebar-2 mh-sidebar-wide" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
<div id="bs_zones-94" class="mh-widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3447, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div><div id="bs_zones-95" class="mh-widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3447, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div><div id="bs_zones-96" class="mh-widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3423, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div><div id="bs_zones-97" class="mh-widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3423, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div><div id="bs_zones-98" class="mh-widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3423, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div><div id="bs_zones-99" class="mh-widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(3423, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']});</script></div></div></aside>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="custom_html-6" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Oswego County Today</span></h6><div class="textwidget custom-html-widget"><div>
Published by: <br>
<b>Dot Publishing, Inc.</b><br>
(315)593-2510<br>
117 Cayuga Street, Fulton, NY 13069
</div>
</div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="custom_html-8" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="http://www.lionpublishers.com/" target="_blank"><img src="https://oswegocountytoday.com/images/lion_memberbadge_horiz.jpg" width="160" height="66" alt=" Lion Publishers" /></a></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
<div id="custom_html-9" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><h1><a href="https://www.CNYAlive.com/" target="_blank">CNY Alive!</a></h1></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="custom_html-10" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Proudly Designed by Dot Publishing</span></h6><div class="textwidget custom-html-widget"><a href="http://dotpublishinginc.com">All Content Copyright Dot Publishing 2019.</a>
<br>
All Submissions Become Property of Dot Publishing All rights reserved. This material may not be published, broadcast, rewritten, or redistributed.</div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
Copyright &copy; 2019 | MH Magazine WordPress Theme by <a href="https://www.mhthemes.com/" title="Premium WordPress Themes" rel="nofollow">MH Themes</a> </p>
</div>
</div>
<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','lead-story','oswego-6th-ward-councilor-seeks-2nd-term']</script><script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["lead-story","oswego-6th-ward-councilor-seeks-2nd-term"],"url":"lead-story"};</script><script data-cfasync='false'>if (window.broadstreet && window.broadstreet.loadNetworkJS) window.broadstreet.loadNetworkJS(28)</script> <div style="display:none">
</div>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-26399609-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-26399609-1');
</script><div id="fb-root"></div>
<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<div id="sharing_email" style="display: none;">
<form action="/oswego-6th-ward-councilor-seeks-2nd-term/lead-story/" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img style="float: right; display: none" class="loading" src="https://oswegocountytoday.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://oswegocountytoday.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201906'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-includes/js/wp-embed.min.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/oswegocountytoday.com\/wp-admin\/admin-ajax.php","nonce":"4d36a48086","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/oswegocountytoday.com\/wp-login.php?redirect_to=https%3A%2F%2Foswegocountytoday.com%2Foswego-6th-ward-councilor-seeks-2nd-term%2Flead-story%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.9'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.9'></script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.9'></script>
<script async="async" type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://oswegocountytoday.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.9'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<iframe src='https://widgets.wp.com/likes/master.html?ver=201906#ver=201906' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<style type="text/css"></style></body>
</html>