<!DOCTYPE html><html class="no-js mh-two-sb" lang="en-US"><head><meta charset="UTF-8" />
<script src="/cdn-cgi/apps/head/DkoEC9W5rlNFSrMzPKHqaJqOgzQ.js"></script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="profile" href="//gmpg.org/xfn/11" />
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=AzinDjUae3U3PkZ3Rpup66UU";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 243319;
var ezdomain = 'oswegocountytoday.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":243319,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"2100fe8e-65e2-4fd4-4a6c-0653572532da","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":97697,"response_time_orig":4,"serverid":"18.207.118.231:12224","state":"VA","t_epoch":1618335183,"template_id":120,"time_on_site_visit":0,"url":"https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/","user_id":0,"word_count":712,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_243319=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["2100fe8e-65e2-4fd4-4a6c-0653572532da", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body id="mh-mobile" class="post-template-default single single-post postid-286862 single-format-standard custom-background mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout4 mh-header-transparent mh-loop-hide-caption" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div id="pp-banner"></div>
<title>Theodore L. Dann – Oswego County Today</title>
<meta name="robots" content="max-image-preview:large" />
<link rel="dns-prefetch" href="//cdn.broadstreetads.com" />
<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//s.w.org" />
<link rel="dns-prefetch" href="//v0.wordpress.com" />
<link rel="dns-prefetch" href="//widgets.wp.com" />
<link rel="dns-prefetch" href="//s0.wp.com" />
<link rel="dns-prefetch" href="//0.gravatar.com" />
<link rel="dns-prefetch" href="//1.gravatar.com" />
<link rel="dns-prefetch" href="//2.gravatar.com" />
<link rel="dns-prefetch" href="//jetpack.wordpress.com" />
<link rel="dns-prefetch" href="//s1.wp.com" />
<link rel="dns-prefetch" href="//s2.wp.com" />
<link rel="dns-prefetch" href="//public-api.wordpress.com" />
<link rel="dns-prefetch" href="//c0.wp.com" />
<link rel="dns-prefetch" href="//i0.wp.com" />
<link rel="dns-prefetch" href="//i1.wp.com" />
<link rel="dns-prefetch" href="//i2.wp.com" />
<link rel="alternate" type="application/rss+xml" title="Oswego County Today » Feed" href="https://oswegocountytoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oswego County Today » Comments Feed" href="https://oswegocountytoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oswego County Today » Theodore L. Dann Comments Feed" href="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/oswegocountytoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet" id="wp-block-library-css" href="https://c0.wp.com/c/5.7/wp-includes/css/dist/block-library/style.min.css" type="text/css" media="all" />
<style id="wp-block-library-inline-css" type="text/css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mh-magazine-css" href="https://oswegocountytoday.com/wp-content/themes/mh-magazine/style.css?ver=3.9.9" type="text/css" media="all" />
<link rel="stylesheet" id="mh-font-awesome-css" href="https://oswegocountytoday.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css" type="text/css" media="all" />
<link rel="stylesheet" id="mh-google-fonts-css" href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700%7cTitillium+Web:300,400,400italic,600,700" type="text/css" media="all" />
<link rel="stylesheet" id="social-logos-css" href="https://c0.wp.com/p/jetpack/9.6/_inc/social-logos/social-logos.min.css" type="text/css" media="all" />
<link rel="stylesheet" id="jetpack_css-css" href="https://c0.wp.com/p/jetpack/9.6/css/jetpack.css" type="text/css" media="all" />
<script type="text/javascript" id="jetpack_related-posts-js-extra">
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/related-posts/related-posts.min.js" id="jetpack_related-posts-js"></script>
<script type="text/javascript" data-cfasync="false" src="//cdn.broadstreetads.com/init-2.min.js?ver=5.7" id="broadstreet-cdn-js"></script>
<script type="text/javascript" src="https://c0.wp.com/c/5.7/wp-includes/js/jquery/jquery.min.js" id="jquery-core-js"></script>
<script type="text/javascript" src="https://c0.wp.com/c/5.7/wp-includes/js/jquery/jquery-migrate.min.js" id="jquery-migrate-js"></script>
<script type="text/javascript" src="https://oswegocountytoday.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.9.9" id="mh-scripts-js"></script>
<script type="text/javascript" src="https://www.googletagmanager.com/gtag/js?id=UA-26399609-1" id="google_gtagjs-js" async=""></script>
<script type="text/javascript" id="google_gtagjs-js-after">
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-26399609-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://oswegocountytoday.com/wp-json/" /><link rel="alternate" type="application/json" href="https://oswegocountytoday.com/wp-json/wp/v2/posts/286862" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://oswegocountytoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://oswegocountytoday.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7" />
<link rel="canonical" href="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/" />
<link rel="shortlink" href="https://wp.me/p1shcx-1cCO" />
<link rel="alternate" type="application/json+oembed" href="https://oswegocountytoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://oswegocountytoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F&amp;format=xml" />
<meta name="generator" content="Site Kit by Google 1.29.0" /><style type="text/css">img#wpstats{display:none}</style>
<style type="text/css">
.mh-navigation li:hover, .mh-navigation ul li:hover > ul, .mh-main-nav-wrap, .mh-main-nav, .mh-social-nav li a:hover, .entry-tags li, .mh-slider-caption, .mh-widget-layout8 .mh-widget-title .mh-footer-widget-title-inner, .mh-widget-col-1 .mh-slider-caption, .mh-widget-col-1 .mh-posts-lineup-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-social-widget li a, .mh-author-bio-widget, .mh-footer-widget .mh-tab-comment-excerpt, .mh-nip-item:hover .mh-nip-overlay, .mh-widget .tagcloud a, .mh-footer-widget .tagcloud a, .mh-footer, .mh-copyright-wrap, input[type=submit]:hover, #infinite-handle span:hover { background: #004e82; }
.mh-extra-nav-bg { background: rgba(0, 78, 130, 0.2); }
.mh-slider-caption, .mh-posts-stacked-title, .mh-posts-lineup-caption { background: #004e82; background: rgba(0, 78, 130, 0.8); }
@media screen and (max-width: 900px) { #mh-mobile .mh-slider-caption, #mh-mobile .mh-posts-lineup-caption { background: rgba(0, 78, 130, 1); } }
.slicknav_menu, .slicknav_nav ul, #mh-mobile .mh-footer-widget .mh-posts-stacked-overlay { border-color: #004e82; }
.mh-copyright, .mh-copyright a { color: #fff; }
.mh-widget-layout4 .mh-widget-title { background: #129abc; background: rgba(18, 154, 188, 0.6); }
.mh-preheader, .mh-wide-layout .mh-subheader, .mh-ticker-title, .mh-main-nav li:hover, .mh-footer-nav, .slicknav_menu, .slicknav_btn, .slicknav_nav .slicknav_item:hover, .slicknav_nav a:hover, .mh-back-to-top, .mh-subheading, .entry-tags .fa, .entry-tags li:hover, .mh-widget-layout2 .mh-widget-title, .mh-widget-layout4 .mh-widget-title-inner, .mh-widget-layout4 .mh-footer-widget-title, .mh-widget-layout5 .mh-widget-title-inner, .mh-widget-layout6 .mh-widget-title, #mh-mobile .flex-control-paging li a.flex-active, .mh-image-caption, .mh-carousel-layout1 .mh-carousel-caption, .mh-tab-button.active, .mh-tab-button.active:hover, .mh-footer-widget .mh-tab-button.active, .mh-social-widget li:hover a, .mh-footer-widget .mh-social-widget li a, .mh-footer-widget .mh-author-bio-widget, .tagcloud a:hover, .mh-widget .tagcloud a:hover, .mh-footer-widget .tagcloud a:hover, .mh-posts-stacked-item .mh-meta, .page-numbers:hover, .mh-loop-pagination .current, .mh-comments-pagination .current, .pagelink, a:hover .pagelink, input[type=submit], #infinite-handle span { background: #129abc; }
.mh-main-nav-wrap .slicknav_nav ul, blockquote, .mh-widget-layout1 .mh-widget-title, .mh-widget-layout3 .mh-widget-title, .mh-widget-layout5 .mh-widget-title, .mh-widget-layout8 .mh-widget-title:after, #mh-mobile .mh-slider-caption, .mh-carousel-layout1, .mh-spotlight-widget, .mh-author-bio-widget, .mh-author-bio-title, .mh-author-bio-image-frame, .mh-video-widget, .mh-tab-buttons, textarea:hover, input[type=text]:hover, input[type=email]:hover, input[type=tel]:hover, input[type=url]:hover { border-color: #129abc; }
.mh-header-tagline, .mh-dropcap, .mh-carousel-layout1 .flex-direction-nav a, .mh-carousel-layout2 .mh-carousel-caption, .mh-posts-digest-small-category, .mh-posts-lineup-more, .bypostauthor .fn:after, .mh-comment-list .comment-reply-link:before, #respond #cancel-comment-reply-link:before { color: #129abc; }
.entry-content a { color: #4498e2; }
</style>
<!--[if lt IE 9]>
<script src="https://oswegocountytoday.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
.entry-content { font-size: 18px; font-size: 1.125rem; }
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Titillium Web", sans-serif; }
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
<script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-5212947836907468","enable_page_level_ads":true,"tag_partner":"site_kit"});</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Theodore L. Dann" />
<meta property="og:url" content="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/" />
<meta property="og:description" content="Theodore L. Dann, 82, of Hannibal, passed away on Friday, April 9, 2021." />
<meta property="article:published_time" content="2021-04-12T19:09:51+00:00" />
<meta property="article:modified_time" content="2021-04-12T19:09:51+00:00" />
<meta property="og:site_name" content="Oswego County Today" />
<meta property="og:image" content="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=385%2C372&amp;ssl=1" />
<meta property="og:image:width" content="385" />
<meta property="og:image:height" content="372" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Theodore L. Dann" />
<meta name="twitter:image" content="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=385%2C372&amp;ssl=1&amp;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/08/cropped-OCTAvatar.jpg?fit=32%2C32&amp;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/08/cropped-OCTAvatar.jpg?fit=192%2C192&amp;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/08/cropped-OCTAvatar.jpg?fit=180%2C180&amp;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/08/cropped-OCTAvatar.jpg?fit=270%2C270&amp;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.no-post-thumbnail .entry-featured {
    display: none;
}
.single-post .entry-thumb {
  display: none;
}			</style>
<aside class="mh-container mh-header-widget-1">
<div id="text-2" class="mh-widget mh-header-1 widget_text"> <div class="textwidget"><div id="pp-banner"></div>
</div>
</div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<div class="mh-preheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
</div>
<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
<div class="mh-header-date mh-header-date-top">
April 12, 2021 </div>
</div>
</div>
</div>
<header class="mh-header" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="mh-container mh-container-inner clearfix">
<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="https://schema.org/Brand">
<div class="mh-header-text">
<a class="mh-header-text-link" href="https://oswegocountytoday.com/" title="Oswego County Today" rel="home">
<h2 class="mh-header-title">Oswego County Today</h2>
<h3 class="mh-header-tagline">FREE Independent News for Oswego County</h3>
</a>
</div>
</div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="bs_sbszones-2" class="mh-widget mh-header-2 bs_sbszones">
<table border="0" width="100%" style="margin-bottom: 10px;">
<tbody><tr>
<td align="center">
<script type="text/javascript">broadstreet.zone(3454);</script>
</td>
<td align="center">
<script type="text/javascript">broadstreet.zone(3454);</script>
</td>
</tr>
</tbody></table>
</div></aside>
</div>
</div>
</div>
<div class="mh-main-nav-wrap">
<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-73602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-73602"><a href="https://oswegocountytoday.com">Home</a>
<ul class="sub-menu">
<li id="menu-item-149540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149540"><a href="https://oswegocountytoday.com/category/emergency/">Emergency Posts</a></li>
<li id="menu-item-128470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-128470"><a href="https://oswegocountytoday.com/category/weather/">Today’s Weather</a></li>
</ul>
</li>
<li id="menu-item-73614" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73614"><a href="https://oswegocountytoday.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-73623" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73623"><a href="https://oswegocountytoday.com/category/lead-story/">Lead Story</a></li>
<li id="menu-item-283841" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-283841"><a href="https://oswegocountytoday.com/category/politics/">Politics</a></li>
<li id="menu-item-236423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236423"><a href="https://oswegocountytoday.com/category/mayorminutes/">Mayor Minutes</a></li>
<li id="menu-item-73616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73616"><a href="https://oswegocountytoday.com/category/news/fulton/">Fulton Daily News</a>
<ul class="sub-menu">
<li id="menu-item-261703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261703"><a href="https://oswegocountytoday.com/category/news/fulton/fulton-a-history/">Fulton, A History</a></li>
</ul>
</li>
<li id="menu-item-73617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73617"><a href="https://oswegocountytoday.com/category/news/oswego/">Oswego Daily News</a></li>
<li id="menu-item-73615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73615"><a href="https://oswegocountytoday.com/category/community/">Community</a></li>
<li id="menu-item-73625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73625"><a href="https://oswegocountytoday.com/category/oswego-tourism/">Oswego Tourism</a></li>
<li id="menu-item-131105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131105"><a href="https://oswegocountytoday.com/category/raidernet-daily/">RaiderNet</a></li>
<li id="menu-item-116546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-116546"><a href="https://oswegocountytoday.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-116548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-116548"><a href="https://oswegocountytoday.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
</ul>
</li>
<li id="menu-item-73618" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-73618"><a href="https://oswegocountytoday.com/category/obituaries/">Obituaries</a>
<ul class="sub-menu">
<li id="menu-item-200925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-200925"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/allanson-glanville-tappan-funeral-home/">Allanson Glanville Tappan Funeral Home</a></li>
<li id="menu-item-272365" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-272365"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/brown/">Brown Funeral Home</a></li>
<li id="menu-item-200705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-200705"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/dain-cullinan-funeral-home/">Dain-Cullinan Funeral Home</a></li>
<li id="menu-item-200303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-200303"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/dowdle-funeral-home/">Dowdle Funeral Home</a></li>
<li id="menu-item-73634" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-73634"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/foster-funeral-home-funeral-homes/">Foster Funeral Home</a></li>
<li id="menu-item-246243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-246243"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/menter/">Menter Funeral Home</a></li>
<li id="menu-item-263611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-263611"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/nelson/">Nelson Funeral Home</a></li>
<li id="menu-item-73633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73633"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/sugar-and-sugar-scanlon-funeral-homes/">Sugar and Sugar Scanlon Funeral Homes</a></li>
</ul>
</li>
<li id="menu-item-73620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73620"><a href="https://oswegocountytoday.com/category/police/">Police Blotter</a>
<ul class="sub-menu">
<li id="menu-item-73621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73621"><a href="https://oswegocountytoday.com/category/police/police-blotter-fdn/">Fulton Police</a></li>
<li id="menu-item-73622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73622"><a href="https://oswegocountytoday.com/category/police/police-blotter-odn/">Oswego Police</a></li>
<li id="menu-item-73632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-73632"><a href="https://oswegocountytoday.com/category/police/sherrifs-department-fdn/">Sheriff’s Department</a></li>
</ul>
</li>
<li id="menu-item-73629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-73629"><a href="https://oswegocountytoday.com/category/oswegohealth/">Oswego Health</a>
<ul class="sub-menu">
<li id="menu-item-280005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-280005"><a href="https://oswegocountytoday.com/category/oswegohealth/todays-health-tips/">Today’s Health Tips</a></li>
<li id="menu-item-280006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-280006"><a href="https://oswegocountytoday.com/category/oswegohealth/health/">Health</a></li>
</ul>
</li>
<li id="menu-item-250048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-250048"><a href="https://oswegocountytoday.com/category/pethealth/">Pets</a></li>
<li id="menu-item-149546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149546"><a href="https://oswegocountytoday.com/category/realestate/">Real Estate</a></li>
<li id="menu-item-149548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149548"><a href="https://oswegocountytoday.com/category/sports/">Sports</a></li>
<li id="menu-item-150766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-150766"><a href="https://oswegocountytoday.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
<li id="menu-item-210439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-210439"><a title="CNY Music and Entrtainment" href="https://cnyalive.com">CNY Alive!</a></li>
</ul>
</li>
</ul></div> </nav>
</div>
</header>
<div class="mh-subheader">
<div class="mh-container mh-container-inner mh-row clearfix">
<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
<div class="mh-header-ticker mh-header-ticker-bottom">
<div class="mh-ticker-bottom">
<div class="mh-ticker-content mh-ticker-content-bottom">
<ul id="mh-ticker-loop-bottom"> </ul>
</div>
</div> </div>
</div>
<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
<aside class="mh-header-search mh-header-search-bottom">
<form role="search" method="get" class="search-form" action="https://oswegocountytoday.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search …" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </aside>
</div>
</div>
</div>
<div class="mh-wrapper clearfix">
<div class="mh-main clearfix">
<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb" itemscope="" itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem"><a href="https://oswegocountytoday.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://oswegocountytoday.com/category/obituaries/">Obituaries</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/">Funeral Homes</a><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem"><a href="https://oswegocountytoday.com/category/obituaries/funeral-homes/foster-funeral-home-funeral-homes/" itemprop="item"><span itemprop="name">Foster Funeral Home</span></a><meta itemprop="position" content="2" /></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Theodore L. Dann</nav>
<article id="post-286862" class="post-286862 post type-post status-publish format-standard has-post-thumbnail hentry category-foster-funeral-home-funeral-homes tag-theodore-l-dann">
<header class="entry-header clearfix"><h1 class="entry-title">Theodore L. Dann</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://oswegocountytoday.com/author/contributor/">Contributor</a></span>
</div>
</header>
<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?resize=385%2C372&amp;ssl=1" alt="" title="Dann, Theodore" />
<figcaption class="wp-caption-text">Theodore L. Dann</figcaption>
</figure>
<p>HANNIBAL, NY – Theodore L. Dann, 82, of Hannibal, passed away on Friday, April 9, 2021.</p>
<p>Born in Fulton, a son to the late Theodore C. and Bernice (Griswold) Dann, he was a lifelong resident of Hannibal. Ted served in US Navy from 1956-1959. He worked as a maintenance technician for Niagara Mohawk Power Co., retiring after 31 years. Ted was also a volunteer for the Hannibal Fire Department. He enjoyed photography, woodworking, fishing and cooking. Ted especially loved his New York Yankees.</p>
<p>He was predeceased by his devoted wife of 55 years, Kathleen Dann on January 11, 2021.</p>
<p>Ted will be greatly missed by his children, Thomas (Lisa) Dann, Suzanne (Michael) Naler, Kimberly (Gary) Blumer and Christine Britton; six grandchildren, Jeffrey, Dustin, Dylan, Taylor, Hunter and Cheyanna; two sisters, Bonnie Hopkins and MaryJane Beckwith; two nieces, Lori and Amy and one nephew, Brian.</p>
<p>Calling hours will be from 4 to 6 p.m. on Thursday, April 15 at Foster Funeral Home, 837 Cayuga Street, Hannibal.</p>
<p>A graveside service will be held for both Theodore and Kathleen at noon on Friday, April 16 at St. Mary’s Cemetery, Fulton.</p>
<figure id="attachment_286863" aria-describedby="caption-attachment-286863" style="width: 300px" class="wp-caption aligncenter"><img data-attachment-id="286863" data-permalink="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/attachment/dann-theodore/" data-orig-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=385%2C372&amp;ssl=1" data-orig-size="385,372" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="Dann, Theodore" data-image-description="" data-medium-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=300%2C290&amp;ssl=1" data-large-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=385%2C372&amp;ssl=1" loading="lazy" class="size-medium wp-image-286863 jetpack-lazy-image" src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526-300x290.jpg?resize=300%2C290&amp;ssl=1" alt="" width="300" height="290" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?resize=300%2C290&amp;ssl=1 300w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?resize=150%2C145&amp;ssl=1 150w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?w=385&amp;ssl=1 385w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526-300x290.jpg?resize=300%2C290&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><noscript><img data-attachment-id="286863" data-permalink="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/attachment/dann-theodore/" data-orig-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=385%2C372&amp;ssl=1" data-orig-size="385,372" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Dann, Theodore" data-image-description="" data-medium-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=300%2C290&amp;ssl=1" data-large-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?fit=385%2C372&amp;ssl=1" loading="lazy" class="size-medium wp-image-286863" src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526-300x290.jpg?resize=300%2C290&#038;ssl=1" alt="" width="300" height="290" srcset="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?resize=300%2C290&amp;ssl=1 300w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?resize=150%2C145&amp;ssl=1 150w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg?w=385&amp;ssl=1 385w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /></noscript><figcaption id="caption-attachment-286863" class="wp-caption-text">Theodore L. Dann</figcaption></figure>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/" data-text="Theodore L. Dann">Tweet</a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/" data-counter="right"></script></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://oswegocountytoday.com/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-reddit"><div class="reddit_button"><iframe src="https://www.reddit.com/static/button/button1.html?newwindow=true&amp;width=120&amp;url=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F&amp;title=Theodore%20L.%20Dann" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-end"></li></ul></div></div></div><div class="sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded" id="like-post-wrapper-21515645-286862-60749b1d5c16c" data-src="https://widgets.wp.com/likes/#blog_id=21515645&amp;post_id=286862&amp;origin=oswegocountytoday.com&amp;obj_id=21515645-286862-60749b1d5c16c" data-name="like-post-frame-21515645-286862-60749b1d5c16c"><h3 class="sd-title">Like this:</h3><div class="likes-widget-placeholder post-likes-widget-placeholder" style="height: 55px;"><span class="button"><span>Like</span></span> <span class="loading">Loading...</span></div><span class="sd-text-color"></span><a class="sd-link-color"></a></div>
<div id="jp-relatedposts" class="jp-relatedposts">
<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
<a class="mh-facebook" href="#" onclick="window.open(&#39;https://www.facebook.com/sharer.php?u=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F&amp;t=Theodore+L.+Dann&#39;, &#39;facebookShare&#39;, &#39;width=626,height=436&#39;); return false;" title="Share on Facebook">
<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
</a>
<a class="mh-twitter" href="#" onclick="window.open(&#39;https://twitter.com/share?text=Theodore+L.+Dann:&amp;url=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F&#39;, &#39;twitterShare&#39;, &#39;width=626,height=436&#39;); return false;" title="Tweet This Post">
<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
</a>
<a class="mh-linkedin" href="#" onclick="window.open(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F&amp;source=&#39;, &#39;linkedinShare&#39;, &#39;width=626,height=436&#39;); return false;" title="Share on LinkedIn">
<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
</a>
<a class="mh-pinterest" href="#" onclick="window.open(&#39;https://pinterest.com/pin/create/button/?url=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F&amp;media=https://oswegocountytoday.com/wp-content/uploads/2021/04/Dann-Theodore-e1618254565526.jpg&amp;description=Theodore+L.+Dann&#39;, &#39;pinterestShare&#39;, &#39;width=750,height=350&#39;); return false;" title="Pin This Post">
<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
</a>
<a class="mh-email" href="/cdn-cgi/l/email-protection#6a55191f08000f091e573e020f050e05180f4f585a26444f585a2e0b04044c0b071a5108050e1357021e1e1a194f592b4f582c4f582c05191d0f0d0509051f041e131e050e0b13440905074f582c0508031e1f0b18030f194f582c0c1f040f180b06470205070f194f582c0c05191e0f18470c1f040f180b06470205070f470c1f040f180b06470205070f194f582c1e020f050e05180f4706470e0b04044f582c" title="Send this article to a friend" target="_blank">
<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
</a>
<a class="mh-print" href="javascript:window.print()" title="Print this article">
<span class="mh-share-button"><i class="fa fa-print"></i></span>
</a>
</div></div>
</div></article><div id="comments" class="mh-comments-wrap">
<h4 class="mh-widget-title mh-comment-form-title">
<span class="mh-widget-title-inner">
Be the first to comment </span>
</h4>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/#respond" style="display:none;">Cancel reply</a></small>
</h3>
<form id="commentform" class="comment-form">
<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=21515645&amp;postid=286862&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=1&amp;stb_enabled=1&amp;show_avatars=1&amp;avatar_default=blank&amp;greeting=Comment&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=9.6&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=0369db2efc8d64b24be139a91c2e074bddfc37a1#parent=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F" name="jetpack_remote_comment" style="width:100%; height: 430px; border:0;" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
									</iframe>
<!--[if !IE]><!-->
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
<!--<![endif]-->
</form>
</div>
<input type="hidden" name="comment_parent" id="comment_parent" value="" />
</div>
</div>
<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div id="mh_magazine_slider-7" class="mh-widget mh_magazine_slider"> <div class="flexslider mh-slider-widget mh-slider-normal mh-slider-layout1">
<ul class="slides"> <li class="mh-slider-item">
<article class="post-286848 post type-post status-publish format-standard has-post-thumbnail category-lead-story tag-christopher-w-fredenburg tag-cyndal-m-fredenburg tag-fulton tag-fulton-police tag-judge-hawthorne">
<a href="https://oswegocountytoday.com/lead-story/fulton-police-arrest-mother-twice-in-one-week-for-endangering-welfare-of-child/" title="Fulton Police Arrest Mother Twice In One Week For Endangering Welfare Of Child"><img width="678" height="381" src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?resize=678%2C381&amp;ssl=1" class="attachment-mh-magazine-content size-mh-magazine-content wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="283483" data-permalink="https://oswegocountytoday.com/news/fulton/fulton-police-arrest-local-contractor-with-grand-larceny-charge/attachment/fultonpolicelogo/" data-orig-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?fit=1476%2C830&amp;ssl=1" data-orig-size="1476,830" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="Fultonpolicelogo" data-image-description="" data-medium-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?fit=460%2C259&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?w=1476&amp;ssl=1 1476w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?resize=460%2C259&amp;ssl=1 460w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?resize=150%2C84&amp;ssl=1 150w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?resize=678%2C381&amp;ssl=1 678w" data-lazy-sizes="(max-width: 678px) 100vw, 678px" data-lazy-src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/01/Fultonpolicelogo.png?resize=678%2C381&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
<div class="mh-image-caption mh-slider-category">
Lead Story </div>
<div class="mh-slider-caption">
<div class="mh-slider-content">
<h2 class="mh-slider-title">
<a href="https://oswegocountytoday.com/lead-story/fulton-police-arrest-mother-twice-in-one-week-for-endangering-welfare-of-child/" title="Fulton Police Arrest Mother Twice In One Week For Endangering Welfare Of Child">
Fulton Police Arrest Mother Twice In One Week For Endangering Welfare Of Child </a>
</h2>
<div class="mh-excerpt">Fulton Police Department reports a Fulton mother has been arrested twice within one week for allegedly endangering the welfare of a one year old child and a four year old child. The children’s father was <a class="mh-excerpt-more" href="https://oswegocountytoday.com/lead-story/fulton-police-arrest-mother-twice-in-one-week-for-endangering-welfare-of-child/" title="Fulton Police Arrest Mother Twice In One Week For Endangering Welfare Of Child">[...]</a></div> </div>
</div>
</article>
</li> <li class="mh-slider-item">
<article class="post-286512 post type-post status-publish format-standard has-post-thumbnail category-lead-story tag-fulton tag-news tag-oswego tag-oswego-county tag-oswego-county-today tag-top-stories">
<a href="https://oswegocountytoday.com/lead-story/oswego-county-today-weekly-news-roundup-4-4-4-10-21/" title="Oswego County Today Weekly News Roundup: 4/4 – 4/10/21"><img width="678" height="381" src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?resize=678%2C381&amp;ssl=1" class="attachment-mh-magazine-content size-mh-magazine-content wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="279035" data-permalink="https://oswegocountytoday.com/news/oswego-county-county-today-weekly-news-roundup-september-4-september-10-2020/attachment/octweeklyroundup/" data-orig-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?fit=889%2C500&amp;ssl=1" data-orig-size="889,500" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="OCTWeeklyroundup" data-image-description="" data-medium-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?fit=460%2C259&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?w=889&amp;ssl=1 889w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?resize=460%2C259&amp;ssl=1 460w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?resize=150%2C84&amp;ssl=1 150w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?resize=678%2C381&amp;ssl=1 678w" data-lazy-sizes="(max-width: 678px) 100vw, 678px" data-lazy-src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2020/09/OCTWeeklyroundup.jpg?resize=678%2C381&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
<div class="mh-image-caption mh-slider-category">
Lead Story </div>
<div class="mh-slider-caption">
<div class="mh-slider-content">
<h2 class="mh-slider-title">
<a href="https://oswegocountytoday.com/lead-story/oswego-county-today-weekly-news-roundup-4-4-4-10-21/" title="Oswego County Today Weekly News Roundup: 4/4 – 4/10/21">
Oswego County Today Weekly News Roundup: 4/4 – 4/10/21 </a>
</h2>
<div class="mh-excerpt">Oswego County Today presents the top stories of this past week. […] Share this:TweetEmailPrint Like this:Like Loading... Related</div> </div>
</div>
</article>
</li> </ul>
</div></div><div id="mh_magazine_custom_posts-46" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://oswegocountytoday.com/category/news/" class="mh-widget-title-link">News</a></span></h4> <ul class="mh-custom-posts-widget clearfix"> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-286858 post type-post status-publish format-standard has-post-thumbnail category-news tag-bridget-dolbear tag-diane-cooper-currier tag-g-c-foods tag-glow-a-fun-golf-tournament tag-oco tag-oswego-county-opportunities tag-scriba">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://oswegocountytoday.com/news/oco-glow-ball-golf-tournament-set-for-august-20/" title="OCO Glow Ball Golf Tournament Set For August 20"><img width="326" height="245" src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="286859" data-permalink="https://oswegocountytoday.com/news/oco-glow-ball-golf-tournament-set-for-august-20/attachment/diane-briget-at-tamarack/" data-orig-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;8&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;Canon EOS Rebel T7i&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;1617327564&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;18&#34;,&#34;iso&#34;:&#34;100&#34;,&#34;shutter_speed&#34;:&#34;0.003125&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="Diane &amp; Briget at Tamarack" data-image-description="" data-medium-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?fit=460%2C259&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?resize=600%2C450&amp;ssl=1 600w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?zoom=3&amp;resize=326%2C245&amp;ssl=1 978w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Diane-Briget-at-Tamarack-scaled.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/news/oco-glow-ball-golf-tournament-set-for-august-20/" title="OCO Glow Ball Golf Tournament Set For August 20">
OCO Glow Ball Golf Tournament Set For August 20 </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
</div>
</div>
<div class="mh-excerpt">On Friday evening, August 20, OCO will host its inaugural Glow-A-Fun Golf Tournament. Presented by G &amp; C Foods in Syracuse, the Glow-A-Fun Golf Tournament will begin at dusk with teams of four teeing off <a class="mh-excerpt-more" href="https://oswegocountytoday.com/news/oco-glow-ball-golf-tournament-set-for-august-20/" title="OCO Glow Ball Golf Tournament Set For August 20">[...]</a></div> </div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-small clearfix post-286836 post type-post status-publish format-standard has-post-thumbnail category-news tag-april tag-national-sexual-violence-resource-center tag-oco tag-saf tag-services-to-aid-families tag-sexual-assault-awareness-month">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://oswegocountytoday.com/news/ocos-saf-program-recognizes-sexual-assault-awareness-month/" title="OCO’s SAF Program Recognizes Sexual Assault Awareness Month"><img width="80" height="60" src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="286838" data-permalink="https://oswegocountytoday.com/news/ocos-saf-program-recognizes-sexual-assault-awareness-month/attachment/ocologo/" data-orig-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?fit=507%2C285&amp;ssl=1" data-orig-size="507,285" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="ocologo 16:9" data-image-description="" data-medium-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?fit=460%2C259&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/ocologo.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://oswegocountytoday.com/news/ocos-saf-program-recognizes-sexual-assault-awareness-month/" title="OCO’s SAF Program Recognizes Sexual Assault Awareness Month">
OCO’s SAF Program Recognizes Sexual Assault Awareness Month </a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
</div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-small clearfix post-286821 post type-post status-publish format-standard has-post-thumbnail category-news tag-gas tag-gas-report">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://oswegocountytoday.com/news/aaa-gas-prices-report-april-12-2021/" title="AAA Gas Prices Report: April 12, 2021"><img width="80" height="60" src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="281071" data-permalink="https://oswegocountytoday.com/2544-co-rt-57-pumps/" data-orig-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?fit=892%2C575&amp;ssl=1" data-orig-size="892,575" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="2544 Co. Rt. 57 Pumps" data-image-description="" data-medium-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?fit=300%2C193&amp;ssl=1" data-large-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?fit=460%2C297&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?resize=600%2C450&amp;ssl=1 600w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/11/2544-Co.-Rt.-57-Pumps.png?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://oswegocountytoday.com/news/aaa-gas-prices-report-april-12-2021/" title="AAA Gas Prices Report: April 12, 2021">
AAA Gas Prices Report: April 12, 2021 </a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
</div>
</div>
</li> </ul></div><div id="bs_zones-166" class="mh-widget bs_zones"><div><broadstreet-zone zone-id="3423" keywords="not_home_page,not_landing_page,is_article_page,foster-funeral-home-funeral-homes,funeral-homes,theodore-l-dann,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="mh_magazine_custom_posts-48" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://oswegocountytoday.com/category/community/" class="mh-widget-title-link">Community</a></span></h4> <ul class="mh-custom-posts-widget clearfix"> <li class="mh-custom-posts-item mh-custom-posts-large clearfix post-286843 post type-post status-publish format-standard has-post-thumbnail category-community tag-desiree-foss tag-gabriella-greenleaf tag-hannibal-central-school-district tag-jenna-cole tag-jordan-kilgore tag-lauren-boyer tag-magen-darling tag-oswego-county-student-art-show tag-salmon-river-fine-arts-center">
<div class="mh-custom-posts-large-inner clearfix">
<figure class="mh-custom-posts-thumb-xl">
<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://oswegocountytoday.com/community/hannibal-artists-recognized-at-oswego-county-student-art-show/" title="Hannibal Artists Recognized At Oswego County Student Art Show"><img width="326" height="245" src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?resize=326%2C245&amp;ssl=1" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="286844" data-permalink="https://oswegocountytoday.com/community/hannibal-artists-recognized-at-oswego-county-student-art-show/attachment/gabriella-greenleaf-mandala-morning/" data-orig-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?fit=600%2C488&amp;ssl=1" data-orig-size="600,488" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="Gabriella Greenleaf – Mandala Morning" data-image-description="" data-medium-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?fit=300%2C244&amp;ssl=1" data-large-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?fit=460%2C374&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?resize=326%2C245&amp;ssl=1 326w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?resize=80%2C60&amp;ssl=1 80w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?resize=600%2C450&amp;ssl=1 600w" data-lazy-sizes="(max-width: 326px) 100vw, 326px" data-lazy-src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Gabriella-Greenleaf-Mandala-Morning.jpg?resize=326%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-content">
<div class="mh-custom-posts-header">
<h3 class="mh-custom-posts-xl-title">
<a href="https://oswegocountytoday.com/community/hannibal-artists-recognized-at-oswego-county-student-art-show/" title="Hannibal Artists Recognized At Oswego County Student Art Show">
Hannibal Artists Recognized At Oswego County Student Art Show </a>
</h3>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
</div>
</div>
<div class="mh-excerpt">Several Hannibal Central School District students were recently recognized for their artwork submitted into the 25th annual Oswego County Student Art Show. […] Share this:TweetEmailPrint Like this:Like Loading... Related</div> </div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-small clearfix post-286840 post type-post status-publish format-standard has-post-thumbnail category-community tag-25103 tag-birthday tag-doreen-short tag-mary-kon tag-morningstar-residential-care-center">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://oswegocountytoday.com/community/morningstar-celebrates-residents-105th-birthday/" title="Morningstar Celebrates Resident’s 105th Birthday"><img width="80" height="60" src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="286841" data-permalink="https://oswegocountytoday.com/community/morningstar-celebrates-residents-105th-birthday/attachment/kon105/" data-orig-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;5&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;Canon EOS Rebel T7i&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;1617761131&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;33&#34;,&#34;iso&#34;:&#34;1600&#34;,&#34;shutter_speed&#34;:&#34;0.008&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="kon105" data-image-description="" data-medium-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?fit=460%2C259&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?resize=600%2C450&amp;ssl=1 600w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/kon105-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://oswegocountytoday.com/community/morningstar-celebrates-residents-105th-birthday/" title="Morningstar Celebrates Resident’s 105th Birthday">
Morningstar Celebrates Resident’s 105th Birthday </a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
</div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-small clearfix post-286829 post type-post status-publish format-standard has-post-thumbnail category-community tag-art tag-hannibal tag-mexico tag-oswego tag-oswego-county-student-art-show-and-competition tag-phoenix tag-pulaski tag-salmon-river-fine-arts-center tag-winners">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://oswegocountytoday.com/community/winners-announced-for-25th-annual-oswego-county-student-art-show-competition/" title="Winners Announced For 25th Annual Oswego County Student Art Show, Competition"><img width="80" height="60" src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="277168" data-permalink="https://oswegocountytoday.com/news/salmon-river-fine-arts-center-overcomes-pandemic-challenges/attachment/annbuchau/" data-orig-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?fit=2560%2C1440&amp;ssl=1" data-orig-size="2560,1440" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;3.3&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;DSC-W830&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;1397353690&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;4.5&#34;,&#34;iso&#34;:&#34;80&#34;,&#34;shutter_speed&#34;:&#34;0.0125&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="annbuchau" data-image-description="" data-medium-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?fit=460%2C259&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?resize=678%2C509&amp;ssl=1 678w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?resize=326%2C245&amp;ssl=1 326w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?resize=80%2C60&amp;ssl=1 80w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?resize=600%2C450&amp;ssl=1 600w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?zoom=2&amp;resize=80%2C60&amp;ssl=1 160w, https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?zoom=3&amp;resize=80%2C60&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/oswegocountytoday.com/wp-content/uploads/2020/07/annbuchau-scaled.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://oswegocountytoday.com/community/winners-announced-for-25th-annual-oswego-county-student-art-show-competition/" title="Winners Announced For 25th Annual Oswego County Student Art Show, Competition">
Winners Announced For 25th Annual Oswego County Student Art Show, Competition </a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 12, 2021</a></span>
</div>
</div>
</li> </ul></div><div id="mh_magazine_custom_posts-47" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner"><a href="https://oswegocountytoday.com/category/obituaries/" class="mh-widget-title-link">Obituaries</a></span></h4> <ul class="mh-custom-posts-widget clearfix"> <li class="mh-custom-posts-item mh-custom-posts-small clearfix post-286509 post type-post status-publish format-standard has-post-thumbnail category-obituaries">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://oswegocountytoday.com/obituaries/patrick-emmet-hackett-sr/" title="Patrick Emmet Hackett, Sr"><img width="80" height="60" src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="286510" data-permalink="https://oswegocountytoday.com/obituaries/patrick-emmet-hackett-sr/attachment/patrick-hackett-sr-obit-photo/" data-orig-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?fit=1224%2C939&amp;ssl=1" data-orig-size="1224,939" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;1617131856&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;1&#34;}" data-image-title="Patrick-Hackett-Sr.-Obit-Photo" data-image-description="" data-medium-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?fit=300%2C230&amp;ssl=1" data-large-file="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?fit=460%2C353&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?w=1224&amp;ssl=1 1224w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=300%2C230&amp;ssl=1 300w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=460%2C353&amp;ssl=1 460w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=150%2C115&amp;ssl=1 150w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=678%2C509&amp;ssl=1 678w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=326%2C245&amp;ssl=1 326w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=80%2C60&amp;ssl=1 80w, https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=600%2C450&amp;ssl=1 600w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/oswegocountytoday.com/wp-content/uploads/2021/04/Patrick-Hackett-Sr.-Obit-Photo-1.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://oswegocountytoday.com/obituaries/patrick-emmet-hackett-sr/" title="Patrick Emmet Hackett, Sr">
Patrick Emmet Hackett, Sr </a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/04/">April 2, 2021</a></span>
</div>
</div>
</li> <li class="mh-custom-posts-item mh-custom-posts-small clearfix post-284895 post type-post status-publish format-standard has-post-thumbnail category-obituaries">
<figure class="mh-custom-posts-thumb">
<a class="mh-thumb-icon mh-thumb-icon-small" href="https://oswegocountytoday.com/obituaries/jean-ann-kingsley/" title="Jean Ann Kingsley"><img width="80" height="60" src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?resize=80%2C60&amp;ssl=1" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="284822" data-permalink="https://oswegocountytoday.com/obituaries/funeral-homes/dowdle-funeral-home/michael-d-williams/attachment/oswego-county-today-obituaries/" data-orig-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?fit=326%2C245&amp;ssl=1" data-orig-size="326,245" data-comments-opened="0" data-image-meta="{&#34;aperture&#34;:&#34;0&#34;,&#34;credit&#34;:&#34;&#34;,&#34;camera&#34;:&#34;&#34;,&#34;caption&#34;:&#34;&#34;,&#34;created_timestamp&#34;:&#34;0&#34;,&#34;copyright&#34;:&#34;&#34;,&#34;focal_length&#34;:&#34;0&#34;,&#34;iso&#34;:&#34;0&#34;,&#34;shutter_speed&#34;:&#34;0&#34;,&#34;title&#34;:&#34;&#34;,&#34;orientation&#34;:&#34;0&#34;}" data-image-title="obituary file photo 2021" data-image-description="" data-medium-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?fit=326%2C245&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?w=326&amp;ssl=1 326w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?resize=150%2C113&amp;ssl=1 150w, https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?resize=80%2C60&amp;ssl=1 80w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/oswegocountytoday.com/wp-content/uploads/2021/02/Oswego-County-Today-Obituaries.jpg?resize=80%2C60&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</figure>
<div class="mh-custom-posts-header">
<div class="mh-custom-posts-small-title">
<a href="https://oswegocountytoday.com/obituaries/jean-ann-kingsley/" title="Jean Ann Kingsley">
Jean Ann Kingsley </a>
</div>
<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://oswegocountytoday.com/2021/02/">February 21, 2021</a></span>
</div>
</div>
</li> </ul></div> </aside> </div>
<aside class="mh-widget-col-1 mh-sidebar-2 mh-sidebar-wide" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
<div id="bs_zones-28" class="mh-widget bs_zones"><div><broadstreet-zone zone-id="3429" keywords="not_home_page,not_landing_page,is_article_page,foster-funeral-home-funeral-homes,funeral-homes,theodore-l-dann,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-69" class="mh-widget bs_zones"><div><broadstreet-zone zone-id="3429" keywords="not_home_page,not_landing_page,is_article_page,foster-funeral-home-funeral-homes,funeral-homes,theodore-l-dann,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-29" class="mh-widget bs_zones"><div><broadstreet-zone zone-id="3429" keywords="not_home_page,not_landing_page,is_article_page,foster-funeral-home-funeral-homes,funeral-homes,theodore-l-dann,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-124" class="mh-widget bs_zones"><div><broadstreet-zone zone-id="3423" keywords="not_home_page,not_landing_page,is_article_page,foster-funeral-home-funeral-homes,funeral-homes,theodore-l-dann,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div><div id="bs_zones-125" class="mh-widget bs_zones"><div><broadstreet-zone zone-id="3423" keywords="not_home_page,not_landing_page,is_article_page,foster-funeral-home-funeral-homes,funeral-homes,theodore-l-dann,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div></aside>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="https://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-1">
<div id="custom_html-10" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Proudly Designed by Dot Publishing</span></h6><div class="textwidget custom-html-widget"><a href="https://dotpublishinginc.com">All Content Copyright Dot Publishing 2021.</a>
<br />
All Submissions Become Property of Dot Publishing All rights reserved. This material may not be published, broadcast, rewritten, or redistributed.<br />
P.O. Box 3588 <br />
Syracuse, NY 13220<p>
315-593-2510</p>
</div></div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-2">
<div id="custom_html-9" class="widget_text mh-footer-widget widget_custom_html"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Entertainment Magazine and Calendar</span></h6><div class="textwidget custom-html-widget"><h1><a href="https://www.CNYAlive.com/" target="_blank" rel="noopener">CNY Alive!</a></h1>
Not a place to be <br />
but the place to find live local entertainment<br />
in Central New York.</div></div></div>
<div class="mh-col-1-3 mh-widget-col-1 mh-footer-3-cols  mh-footer-area mh-footer-3">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact Us</span></h6><div class="menu-contact-menu-container"><ul id="menu-contact-menu" class="menu"><li id="menu-item-279940" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-279940"><a href="https://oswegocountytoday.com/about-dot-publishing/">About Dot Publishing</a></li>
<li id="menu-item-280339" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-280339"><a href="https://oswegocountytoday.com/contact-us/letters-to-the-editor/">Letters to the Editor</a></li>
<li id="menu-item-277833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-277833"><a href="https://oswegocountytoday.com/submit-a-news-realease/">Submit A News Realease</a></li>
<li id="menu-item-230885" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230885"><a href="https://oswegocountytoday.com/obituary-submition/">Obituary Submission</a></li>
<li id="menu-item-230860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230860"><a href="https://oswegocountytoday.com/contact-us/employment-with-dot-publishing-inc-2/">Employment with Dot Publishing Inc.</a></li>
<li id="menu-item-230861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230861"><a href="https://oswegocountytoday.com/contact-us/advertise-with-us/">Advertise with Oswego County Today</a></li>
<li id="menu-item-230862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230862"><a href="https://oswegocountytoday.com/contact-us/website-terms-of-use/">Website Terms of Use</a></li>
<li id="menu-item-274679" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-274679"><a href="https://oswegocountytoday.com/site-map/">Site Map</a></li>
</ul></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
<div class="mh-container mh-container-inner clearfix">
<p class="mh-copyright">
All Content Copyright Dot Publishing 2021. All Submissions Become Property of Dot Publishing All rights reserved. This material may not be published, broadcast, rewritten, or redistributed. </p>
</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div>
<script data-cfasync="false">window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','foster-funeral-home-funeral-homes','funeral-homes','theodore-l-dann','post']</script>
<script data-cfasync="false">window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["foster-funeral-home-funeral-homes","funeral-homes","theodore-l-dann","post"],"url":"theodore-l-dann"};</script>
<script data-cfasync="false">
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(28);
 });</script><script data-ad-client="ca-pub-5212947836907468" async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/oswegocountytoday.com\/obituaries\/funeral-homes\/foster-funeral-home-funeral-homes\/theodore-l-dann\/":286862,"https:\/\/oswegocountytoday.com\/lead-story\/fulton-police-arrest-mother-twice-in-one-week-for-endangering-welfare-of-child\/":286848,"https:\/\/oswegocountytoday.com\/lead-story\/oswego-county-today-weekly-news-roundup-4-4-4-10-21\/":286512,"https:\/\/oswegocountytoday.com\/news\/oco-glow-ball-golf-tournament-set-for-august-20\/":286858,"https:\/\/oswegocountytoday.com\/community\/hannibal-artists-recognized-at-oswego-county-student-art-show\/":286843};
	</script>
<div id="fb-root"></div>
<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
<script>
			document.body.addEventListener( 'is.post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<script type="text/javascript">
				( function () {
					var currentScript = document.currentScript;

					// Helper function to load an external script.
					function loadScript( url, cb ) {
						var script = document.createElement( 'script' );
						var prev = currentScript || document.getElementsByTagName( 'script' )[ 0 ];
						script.setAttribute( 'async', true );
						script.setAttribute( 'src', url );
						prev.parentNode.insertBefore( script, prev );
						script.addEventListener( 'load', cb );
					}

					function init() {
						loadScript( 'https://platform.linkedin.com/in.js?async=true', function () {
							if ( typeof IN !== 'undefined' ) {
								IN.init();
							}
						} );
					}

					if ( document.readyState === 'loading' ) {
						document.addEventListener( 'DOMContentLoaded', init );
					} else {
						init();
					}

					document.body.addEventListener( 'is.post-load', function() {
						if ( typeof IN !== 'undefined' ) {
							IN.parse();
						}
					} );
				} )();
			</script>
<div id="sharing_email" style="display: none;">
<form action="/obituaries/funeral-homes/foster-funeral-home-funeral-homes/theodore-l-dann/" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img style="float: right; display: none" class="loading" src="https://oswegocountytoday.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/photon/photon.min.js" id="jetpack-photon-js"></script>
<script type="text/javascript" src="https://oswegocountytoday.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2" id="jetpack-lazy-images-polyfill-intersectionobserver-js"></script>
<script type="text/javascript" id="jetpack-lazy-images-js-extra">
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type="text/javascript" src="https://oswegocountytoday.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2" id="jetpack-lazy-images-js"></script>
<script type="text/javascript" src="https://c0.wp.com/c/5.7/wp-includes/js/wp-embed.min.js" id="wp-embed-js"></script>
<script type="text/javascript" id="jetpack-carousel-js-extra">
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/oswegocountytoday.com\/wp-admin\/admin-ajax.php","nonce":"a2a9ba4a3f","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/oswegocountytoday.com\/happy\/?redirect_to=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/carousel/jetpack-carousel.min.js" id="jetpack-carousel-js"></script>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/postmessage.min.js" id="postmessage-js"></script>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/jquery.jetpack-resize.min.js" id="jetpack_resize-js"></script>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/likes/queuehandler.min.js" id="jetpack_likes_queuehandler-js"></script>
<script async="async" type="text/javascript" src="https://oswegocountytoday.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9" id="akismet-form-js"></script>
<script type="text/javascript" id="sharing-js-js-extra">
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://c0.wp.com/p/jetpack/9.6/_inc/build/sharedaddy/sharing.min.js" id="sharing-js-js"></script>
<script type="text/javascript" id="sharing-js-js-after">
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<iframe src="https://widgets.wp.com/likes/master.html?ver=202115#ver=202115" scrolling="no" id="likes-master" name="likes-master" style="display:none;"></iframe>
<div id="likes-other-gravatars"><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=21515645&postid=286862&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Comment&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0369db2efc8d64b24be139a91c2e074bddfc37a1#parent=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=21515645&postid=286862&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=blank&greeting=Comment&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0369db2efc8d64b24be139a91c2e074bddfc37a1#parent=https%3A%2F%2Foswegocountytoday.com%2Fobituaries%2Ffuneral-homes%2Ffoster-funeral-home-funeral-homes%2Ftheodore-l-dann%2F";
					}
				};

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>
<script src="https://stats.wp.com/e-202115.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6',blog:'21515645',post:'286862',tz:'-4',srv:'oswegocountytoday.com'} ]);
	_stq.push([ 'clickTrackerInit', '21515645', '286862' ]);
</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="oswegocountytoday_com",_audins_did=243319;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.oswegocountytoday_com,DomainId.243319" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>